Dexworld.org

Well itís finally good to see you!

Welcome to the Dexworld.org forums. We like new folks around here, so since you're not registered yet, why donít you drop us a little note so we can get to know you?

We will be more than happy to show you more of our tight little community once we know who you are.

Go Back   Dexworld.org > General > Tech Support
User Name
Password
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
Old 11-16-2021, 07:11 PM   #1
Stu Pidazole
Sorry, I don't speak tard

 
Stu Pidazole's Avatar
 
Join Date: Jun 2007
Location: Wyoming
Posts: 943
Default GPU died, but I got better

My gaming rig is a few years old, but new enough for a solid state Hard drive that didn't cost an arm and a leg. The video output crashed last week, and while I thought the graphics card might be the culprit, I didn't want to throw uneducated money at it.

I found a local kid (kid, ha, he's 38 years old, but his mom runs his business), who diagnosed a bad card. He put a crappy but cheap used Radeon HD 4870 1 GB from about 2008 to get me up and running again. It keeps up okay on DoD, but has a few issues with the video settings I ran on the old Powercolor Radeon R7 370 2GB. Downloading the most recent AMD driver was a fustercluck, and I had to bail out and go back to the older driver.

Apparently, like houses, cars, and other things dependent on semiconductors, graphics cards or any other computer component has seen a big price increase. I've got a MSI GeForce gaming GTX 1050 4GB coming from NewEgg. It's about twice the price it was last year.
Stu Pidazole is offline   Reply With Quote
Old 11-23-2021, 02:33 PM   #2
WayFastWhitie
1337
 
WayFastWhitie's Avatar
 
Join Date: Dec 2005
Location: Anaheim, CA
Posts: 457
Default

computers get old fast, my fiance was using my microsoft surface pro for her work during covid lock down (she works for a school district) and it took a shit so she was using her crappy, tiny google laptop the school gave her so i decided to finally hook up my old computer for her. turns out it was so old i couldnt get it to connect to the internet to get any drivers lol. ended up spending like $500 for the rig i have now and its 100x better then my old computer. its got AMD Ryzen 3 3200G with Radeon Vega Graphics 3.60 GHz, a 250g sata ssd and a 1tb external ssd, nvidia gforce gtx1060 6gb graphics. amazing for the money.
WayFastWhitie is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 12:56 AM.


vBulletin Version 3.8.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.